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Introduction 
The purpose of this training module is to build familiarity with the basic functions of CADfix and EMA3D. 

By building a very simple plane model, you will learn basic geometry creation and modification 

techniques. Due to the limited nature of this training module, many CADfix techniques won’t be shown. 

In later modules, more advanced techniques will be explored. 

Almost everything in CADfix can be done using either a GUI (graphic user interface) or using a command 

line input. In this training, both methods will be shown for the applicable steps. Often, beginning users 

find the GUI easier than the command line. However, the command line can greatly increase efficiency 

and more naturally lends itself to the creation of user-written macros. 

Once the plane geometry is constructed, you will follow the steps to turn the CADfix model into an 

EMA3D simulation. The process shown in this module is intentionally left basic to prevent tedium. 

Note: This training was made using CADfix 10 SP2.0 

Things to Keep in Mind 
There are some quirks to keep in mind when using CADfix/EMA3D: 

 The position of the mouse determines the focus of the program. In other words, keyboard 

entries will go into the window underneath the mouse cursor. 

 Geometries are grouped into sets. 

 There is a set manager that can be found in Utilities->Set Manager. This can be used as a GUI 

equivalent for the command line SET commands shown later in the document. 

 While a set is open, it will collect all newly created geometry. More than one set can be open at 

a time. 

 When using the CADfix command line, the “Delete” key acts as a single backspace. 

 When using the CADfix command line, the “Backspace” key deletes the whole line. 

 When using the CADfix command line, the back arrow deletes to the next whitespace. 

 The escape button clears the current geometry selection/highlighting. 

Getting Started 
1. Open CADfix 

2. Click the “Open Model” button at the top left of the screen 
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3. Navigate to a folder to hold the files created during this training 

4. Type a file name into the “File name” text field and click “Import” (this will open the file entered 

or create it if it doesn’t exist) 

5. An empty model should be opened. The background might be a dark gradient. To change it to 

white, do one of the following: 
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a. Navigate to Display Settings (View->Display Settings). Under the “Basic” tab, change the 

screen background colour to white using the dropdown menu. Change the background 

shading to solid. Leave the other fields unchanged. Click “OK.” 

 

b. Alternatively, locate the command line at the bottom of the screen and type: 

PLOC BGND W 

Then hit enter. To see the change, type REP and hit enter. This will repaint the image. 

“PLOC” accesses the display settings, “BGND” accesses the background settings, “W” is 

white  
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6. To get a helpful command menu on the screen (you’ll want this), type PLOC MENU ON and hit 

enter. To force the menu to appear, you’ll have to resize the screen. Now CADfix should look like: 

Constructing Geometry 
Now we’re ready to start making a simple airplane. We’ll make wings, fuselage, and empennage. The 

geometry used in CADfix is composed primarily of points, lines, shapes, surfaces, and bodies. Points are 

the lowest level entities that can be connected to build lines. Lines can be connected into surfaces (with 

an embedding shape). Surfaces can be connected to build bodies. However, bodies are computationally 

heavy for EMA3D simulations and will be avoided in most models. 

Fuselage 
The fuselage will be represented by a rectangular box with rounded forward face, which will represent 

the cockpit. Our fuselage will be about 35 meters long. There are many possible methods to build a 

simple box: 

1. Use “Cube” primitive in the “Primitives” toolbox to create a box body, then delete the body but 

keep the surfaces of the cube. 

2. Create lower level geometries to make the box using the GUI. 

3. Create lower level geometries to make the box using the command line. 

We’ll start by using the primitive: 

1. Make sure the primitives toolbox is open. It should be on the right edge of the window. If it isn’t 

there, activate it by navigating: Tools->Toolbox->Primitives. 
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2. Click the “Cube” tool. It should be the first tool in the toolbox 

3. The box will be 33 m long, anticipating 2 m of cockpit. Fill in the parameters as follows (units are 

in millimeters by default): 

4. Type PLOT SI ALL and hit enter.  

a. “PLOT” tells CADfix to clear the image, then add something to the image, i.e. to plot it 

b. “SI” is the type code for shaded surfaces 

c. “ALL” tells CADfix what part of the model to plot, in our case “all” or everything 

5. You should now see a pink box. Using the left mouse button, you can rotate the model. As you 

rotate, you may notice one side is darker than the others. This is a result of CADfix’s default 

shading setting. We can change it to look better. Type PLOC SHAD BOTH and hit enter 
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a. This tells CADfix to shade faces of surfaces the same regardless of normal direction. In 

other words, the inside of a box or surface will be lighted the same as the outside. 

b. You will need to repaint the picture by typing REP in the command line before you can 

see the changes. 

Original image on left, image after changing shading setting on right 

 

 

6. You’ll want to keep track of the fuselage. Put it in a set named FUSELAGE. 

a. Click on the “Pick bodies” tool. If it isn’t available, click the “Basic selection” cursor. 

b. Pick the box you just made. 

c. With the box still selected, type SETA FUSELAGE SELE. This tells CADfix to add the 

selected items to a set named FUSELAGE. 

d. Right now, FUSELAGE only contains the body. We want all of the points, lines, and 

surfaces, too. Type COMP FUSELAGE. This tells CADfix to complete the set, adding the 

lower level components. 

(for more information on set management, see “CADfix Notes” in the appendix) 

7. As mentioned earlier, bodies are computationally heavy and we don’t want them. 

a. Print the names of the bodies in FUSELAGE: PRNT B FUSELAGE 

b. There should only be one body listed. Delete it: DEL B name, where “name” is the body 

name. For the default naming convention, it is W1. 
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Create a cockpit: 
1. Open a set to hold the cockpit (an open set will put all new geometry inside it): SETO COCKPIT  

2. Make a point at the origin. This can be done by either using the GUI or commands: 

a. Command line: PNT ! 0 0 0. The “!” tells CADfix to automatically name the point. 

b. GUI: Find the “Tools” tab, then enter the “Build” tree, then click on “Create/edit points.” 

c. Create a point at the origin using the tool by clicking “Apply.” 
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3. Add the cockpit points to the image: PLUS PA COCKPIT.  “Plus” adds items to the image without 

removing other entities from the image. The “PA” means points annotated with names. 

4. Create a midpoint between opposite corners of the square face by doing one of the following: 

a. Command line: PNT ! pnt1 pnt2 0.5 

i. Creates point halfway between points “pnt1” and “pnt2.” 

ii. When selecting points, you can use the cursor to select them rather than typing 

their names if you use the arrow keys to highlight “-- pnt” in the menu on the 

right. 

iii. “pnt1” and “pnt2” are opposite corners of the square face (Q1 and Q8 for 

example). 

b. GUI: In the “Create/edit points” tools, select the “Point along a path” tool. Select the 

corners of the square face and leave the ratio at 0.5. Click “Apply.” 

5. Create arcs connecting the corners of the square with the point at the origin. This can be done 

with command line or GUI: 

a. Command line: 

i. LINE ! pnt1 pnt2 centerpnt, where “pnt1” and “pnt2” are arc endpoints and 

“centerpnt” is the center of the arc. The center point is the midpoint of the 

square face. 

ii. Points can be selected with the mouse without typing their names. 

b. GUI: 
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i. Navigate to the “Create\edit lines” tools under Tools->Build. Select the arc tool. 

ii. Select the start, end, and center points. Click “Apply.” 

6. Add the new geometry to the image: PLUS G COCKPIT 

7. At this point, you can see that the cockpit isn’t very pointy. Let’s move the forward point to 

make the airplane sleeker. 

a. Command line: MOVE pnt TRA -1000 0 0 

i. To select the point, use the up/down arrow keys to highlight “pnt” in the side 

menu. Now you can use the mouse to pick the points instead of typing their 

names. 

ii. “TRA” indicates a TRAnslation is to be used (there are options for other kinds of 

transformations, too). 

b. GUI: 
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i.  In the “Tools” tab, find the “Move/Copy” tool under the “Build” tree.  

ii. Select “Move.” 

iii. Select the “Translate” tool (the default). 

iv. From the dropdown menu, choose point entity types. 

v. Select the point at the origin. 

vi. Click “Define…” A new window will pop up. 

vii. Select “Absolute.” 
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viii. Enter -1000 in the “dX” field. 

ix. Click “OK.” 

x. Click “Apply.” 

8. We’re about to create surfaces with the new lines. First, let’s delete the square face so the 

cockpit and fuselage share the same interior. 

a. Select the “Pick surfaces” tool.  

b. Pick the square face. Make sure that the surface is the only thing selected. 

c. ZAP SELE (“zap” is similar to the DEL delete command except that it operates on sets) 
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9. Make cockpit surfaces: 

a. Find the “Create/edit surfaces” tools under the “Tools” tab, “Build” tree. 

b. In the “General Surface” tab (the default), select the lines that will be the edges of the 

new surface. These will be two adjacent arcs and the connecting straight line on the 

fuselage. 

c. Click “Apply.” 

d. On the pop-up window, click “OK.” 

e. Repeat steps a-d for the remaining three surfaces. 

10. Repaint the picture to see all of the new geometry. 

11. Close all open sets to keep it organized: SETC ALL 

Wings 
The wings will be 1 meter tall, 1/2 meter from the bottom of the fuselage, and have a total wingspan of 

30 m, and start 18 m aft of the forward tip of the cockpit. One wing will be created, then it will be 

mirrored to the other side. As with the fuselage, there are several ways to start: 

1. Use “Cube” primitive in the “Primitives” toolbox to create a box body, then delete the body but 

keep the surfaces of the cube. 

2. Create lower level geometries to make the box using the GUI. 

3. Create lower level geometries to make the box using the command line. 

Because the “Cube” technique was already shown for the fuselage, the wings will be built by 

constructing the lower level geometries. The sweep technique will be extensively used, where a lower 

level entity is swept through space to create a higher level entity. 

1. Open a set for the left wing: SETO LEFTWING 

2. Clear or wipe the display: WIPE 

3. Create a master set for the airplane and add the cockpit and fuselage. This will help organize 

things for visualization: SETA PLANE COCKPIT FUSELAGE 

4. Plot the lines of the plane: PLOT L PLANE 

5. Open the master set: SETO PLANE (this will automatically put the left wing in the master set). 

6. Create a point at (17000, -500, 2000): 
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a. PNT ! 17000 -500 2000 

b. Use these coordinates in the GUI tool (shown in Fuselage Section). 

7. Add the new point to the image: PLUS PA LEFTWING 

8. Sweep the new point aft 5 meters:  

a. SWEP pnt ! TRA 5000 0 0, where “pnt” is the point you just made. 

b. Or, use the GUI tool to sweep: 

i. Under “Create/edit lines,” use the “Swept line” tool.  

ii. Pick the start point. 

iii. Click “Define…” 

iv. In the pop-up, select “Absolute.” 

v. Enter 5000 in the “dX” field. 

vi. Click “OK.”  

9. Repaint the picture: REP 

10. Sweep the new line down 1 meter to make a surface:  

a. Command line: SWEP line ! TRA 0 -1000 0, where “line” is the new line. 

b. Or, use the GUI tool: 

i. Under “Create/edit surfaces,” use the “Swept surface” tool. 

ii. Pick the start line. 
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iii. Click “Define…” 

iv. In the pop-up, select “Absolute.” 

v. Enter -1000 in the “dY” field. The other fields should be zero. 

vi. Click “OK.”  

11. To construct the wing, can either sweep the surface you just made to create a body or sweep 

the lines to create surfaces. If you create a body, you’ll have to delete the body. Because this 

process was already shown when making the fuselage, this document will now show how to 

sweep the lines to make surfaces. Another surface will be needed to close the wing. 

a. Sweep with command line: 

b. activate the “Pick lines:”  

i. Pick the lines that bound the surface created in step 10 (if they aren’t visible, 

make sure to repaint the picture) 

ii. Enter: SWEP SELE ! TRA 0 0 13000 

iii. Repaint the picture: REP 

c. Sweep with GUI: 

i. Follow steps in 10b, choosing the lines created in step 10 as starting points. 

Instead of entering -1000 in the dY field, enter 13000 in dZ (leaving the others 

zero). 

ii. You will need to sweep each line individually with the GUI. 

d. Close the wing: 
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i. Add wing surfaces to the image, colored green: PLUS SI LEFTWING G 

ii. Use the “General surface” tool to close the gap in the wing. See steps 9a-9d 

from the Cockpit section for more details. 

iii. Repaint the picture 

12. Check what sets are open and close the ones that aren’t “PLANE”: 

a.  Type PRNT SE 

b. Close any sets that aren’t “PLANE:” SETC LEFTWING 

13. Mirror the leftwing to the right side (X-Y transformation): 

a. Using the GUI: 

i. Navigate to the “Move/Copy” tool in the “Build” tree, under the “Tools” tab. 

ii. Click “Copy.” 

iii. Switch to the “Mirror” option. 

iv. Type “LEFTWING” into the selection field and hit enter. This will select 

everything in the LEFTWING set for copying. 

v. In the dropdown menu for point selection, choose “Pick mid-point of line.” 
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vi. Select the upper and lower lines at the rear face of the fuselage, as well as the 

upper line where the cockpit joins the fuselage. Midpoints of these lines will 

make an X-Y plane. 

vii. Click “Apply.” 
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viii. A popup will ask for a “New part name,” enter “RIGHTWING.” This will put the 

new wing in a set named RIGHTWING. 

ix. Click “OK.” 

b. Command line: First make a mirror transformation, then copy using that transformation. 

i. Create three points that form an x-y plane using your preferred method. Note 

the names. 

ii. Create a transformation named XYMIRROR:  

TRFM XYMIRROR MIR pnt1 pnt2 pnt3 

iii. Copy the leftwing into RIGHTWING using the XYMIRROR transformation: 

COPY LEFTWING RIGHTWING XYMIRROR 

You can use this same transformation for all x-y mirrors (for future mirroring, 

skip straight to step iii). 

14. Plot all of the shaded surfaces in PLANE in blue: PLOT SI PLANE B  

Vertical Stabilizer  
To make the vertical stabilizer, we will copy, rotate, and move one of the wings. Because our wing is off-

center with respect to the centerline of the fuselage, we can’t conveniently rotate the existing wing 
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using the centerline to create a centered and flush stabilizer. To remedy this, we will create a copy of 

the wing so it is centered with the fuselage, then rotate it. 

1. Plot the lines in PLANE: PLOT L PLANE 

2. Add the points (with labels) to the image: PLUS PA ALL 

3. Create a copy of LEFTWING and move it 1.5 meters up. Call the copy TAIL:  

COPY LEFTWING TAIL TRA 0 1500 0 (for GUI instructions, see the Cockpit section step 7) 

4. Navigate to the “Move/Copy” tool. 

5. Select “Move.” 

6. Type “TAIL” into the selection box. 

7. Switch to the “Rotate” option. 

8. Select “Two points” to define the axis of rotation. 

9. Choose the point at the tip of the cockpit and a point directly aft of the tip. 

10. Enter “-90.0” as the angle (right hand rule determines the sign). 

11. Click “Apply.” 

12. Wipe all points from the image to help visibility: WIPE PA 

13. Add the surfaces of the tail to the image, in green: PLUS SI TAIL G 

14. Move the tail aft 11 meters: 

a. MOVE TAIL TRA 11000 0 0 

b. Repaint the image 

15. Shorten the tail: 

a. Navigate to the “Move/Copy” tool. 

b. Select “Move.” 

c. In the selection dropdown, pick surfaces. 

d. Select the upper face of the tail. 

e. Stay on the “Translate” option. 
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f. Select “Two points” for the vector definition. (When using “Two points” for a vector 

definition, the relative difference between the two points creates the vector. The 

absolute position of the points don’t make any difference.) 

g. For the first point, select a corner of the upper face. 

h. For the second point, use the dropdown to change to “Position on line” and pick a 

position along the line underneath the first point. The position you pick will be the new 

height of the tail, so pick a height that looks reasonable (around 1/3 the total height 

works well). 

i. Click “Apply.” 

j. Repaint the picture. 
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Finishing Touches 
The airplane doesn’t look much like an airplane. Let’s assign a realistic color to it. 

1. Plot the plane using assigned colors: PLOT SI PLANE ASGD 

2. Notice the pink coloring. Pink is the default if no color is assigned. 

3. Select the “Pick surfaces” tool. 

4. Fit the entire plane in the image. 

5. Then activate “Box select” by clicking on it. This will let you drag the mouse over an area to 

select it. 

6. Select the entire plane. 

7. Right click anywhere on the image and select “Properties.” 

8. In the color dropdown menu, pick a color. In the example, a dark gray was chosen. 

9. Click “Apply.” 

10. Repaint the picture. 

Cockpit Window 
We have a basic plane, but no one could fly it. Let’s add a window to the cockpit. This step will show 

how to use a very powerful variant of the “Move/Copy” tool and how to modify existing surfaces. 

Methods like these are extremely useful in constructing a CEM. 

1. Plot the cockpit surfaces with assigned color: PLOT SI COCKPIT ASGD 

2. Add the cockpit lines: PLUS L COCKPIT 

3. Check which sets are open: PRNT SE 

4. Close any open sets that aren’t PLANE using SETC setname. 

5. Open a new set, WINDOW: SETO WINDOW 

6. Create the lines for the new window: 

a. Navigate to “Create/edit points” in the “Build” tree. 

b. In the default “Coordinates” option, change the dropdown to “Pick position on 

surface…” 
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c. A window will pop up. Select the upper face of the cockpit, being mindful that the 

positive y-axis is up. 

d. The mouse should now look like a crosshair. Select a position on the surface to be the 

lower right corner of the window (from the pilot’s perspective). 

e. Click “Apply.” 

f. Add the point to the image: PLUS PA WINDOW 

g. Sweep the new point up 750 mm using either the command line or the GUI, whichever 

you prefer. For convenience, the command is: SWEP pnt ! TRA 0 750 0, where pnt is the 

point made in the previous step. 

h. Add the new line to the image, in blue: PLUS L WINDOW B 

i. Mirror the line using the “Move/Copy” tool in the “Build” tree: 

i. Make sure “Copy” is selected 

ii. Select the new line 

iii. Use the mirror option 

iv. The plane should be defined by the midpoints of the upper and lower edges of 

the cockpit, along with the tip of the cockpit. 

v. No part name is necessary. 

j. Repaint the picture. 

k. Connect the end points of the two new lines to each other to make a rectangle: 

i. Command line: LINE ! pnt1 pnt2, where pnt1 and pnt2 are the points to 

connect. 

ii. GUI: Navigate to “Create/edit lines” in the “Build” tree. Select the two end 

points and click “Apply.” 

l. Repaint the picture. 

7. Move the window lines onto the cockpit surface: 

a. Navigate to “Move/Copy” 

b. Make sure “Move” is selected. 

c. Use the “Project” option. 

d. Type WINDOW into the selection field in the top right and hit enter. 
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e. For the reference shape, click the top surface of the cockpit. 

f. Click “Define…” so we can pick the direction of projection. 

g. In the top left of the popup, click absolute. 

h. Type any positive number into the “dX” field. In the example, 100 is used. Leave the 

other fields as zeroes. This tells CADfix to only change the X coordinates of the things 

being moved and only in the positive direction. 

If your lines extend past the top of the cockpit, you will have to project a little 

downwards (add a negative number in the dY, -20 for example). 

i. Click “OK.” 

j. Click “Apply.” 
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k. Repaint the picture. It should look like this: 

 

You’ll notice that many more points have been created. This is a result of how CADfix projects lines onto 

embedding shapes. You might also notice that the upper line isn’t perfectly straight. That is because the 

embedding shape isn’t perfectly flat. This detail likely won’t be noticeable when the model is meshed 

into a finite difference problem space. You might notice a line or two without many points (the lower 

line in the picture above). The lack of points is indicative of a failed projection. For any failed projections, 

use the move tool again, this time using “Closest approach” instead of “Define…” Once finished: 

8. Close the WINDOW set: SETC WINDOW 

9. Open the COCKPIT set: SETO COCKPIT 

10. Split the upper cockpit surface using the window lines: 

a. Command line: SSPL surf WINDOW 5 

i. Recall that you can use the arrow keys to highlight “surf” in the menu on the right 

side of the screen, then you can use the mouse to select the surface. 

ii. The “5” at the end of the command is the tolerance. This option tells CADfix how 

accurately to do the split. Units are in model units (mm for this model). 

b. GUI:  
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i. Navigate to the “Split” tree of the “Tools” tab and select “Split surfaces with lines.” 

ii. Pick the top surface of the cockpit. 

iii. Type WINDOW into the “Pick lines” field and hit enter. 

iv. Change the tolerance to 5 mm. If the split fails, increase the tolerance. 

v. Click “Apply.” 

vi. Repaint the picture. 

11. The cockpit now has a window shaped division, but isn’t grouped properly in sets. The window 

needs to be added to the WINDOW set and removed from the COCKPIT set.  

a. Press escape to ensure that nothing is selected 

b. Activate the “Pick surfaces” by clicking it above the image. 

c. Pick the window of the cockpit. 

d. Type: SETA WINDOW SELE 

e. Type: SETR COCKPIT WINDOW 
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f. Repaint the picture. The window should disappear. That’s because only the surfaces in 

COCKPIT are being displayed and we just removed the window from that set. 

g. Add the window to the image using assigned colors: PLUS SI WINDOW ASGD 

h. Change the assigned color by selecting the window, right clicking, and entering 

properties. Use the dropdown “colour” menu. 

12. Close all sets: SETC ALL 

13. Plot the entire plane, using assigned colors: PLOT SI PLANE ASGD 

Fuselage Windows 
Let’s add windows to the fuselage. The windows will act as apertures for energy to enter the aircraft for 

the HIRF simulation. The quickest way to create the apertures is: 

 Make the outline for one window on one side of the fuselage 

 Mirror (copy) the outline to the other side of the fuselage 

 Then copy both several times down the length of the fuselage 

 Remove the windows from the fuselage 

Creating the outline 

First, create an outline of a window. For this simple model, assume the windows are square. Use ½ 

meter side length. Make the outline the forward-most window on the left side of the fuselage.  

1. Close all open sets: SETC ALL 

2. Open a new set called APERTURES: SETO APERTURES 

3. Plot the surfaces of the fuselage, then add the lines of the plane for reference. 

4. Create a point at 6000, 1500, 2000: PNT ! 6000 1000 2000 

5. Add the annotated points in APERTURES to the image: PLUS PA APERTURES 

6. Sweep that point towards the tail 0.5 meters: SWEP point ! TRA 500 0 0 

7. Add the lines in APERTURES to the image in a difference color: PLUS L APERTURES C 

8. Sweep the new line down 0.5 meters: SWEP line ! TRA 0 -500 0 

9. Add the surfaces in APERTURES to the image: PLUS SI APERTURES ASGD 

a. You can now assign a color if you’d like to (the color assignment will be copied with the 

outline, so it’s easiest to change it now rather than later). 

You should now have a little square surface as a window. 

Mirroring the outline 

Leave APERTURES open. Using your preferred method, mirror a copy of the outline to the other side of 

the fuselage. Refer to the “Wings” section, part 13 for instructions for command line and GUI options. 

Regardless of the method, use the default name for the mirrored part (use ! for the command line COPY 

command – if using the GUI, leave the name popup prepopulated). 

Copying the outlines 

There are now outlines on each side of the fuselage in the APERTURES set. Leaving the APERTURES set 

open, copy the outlines through the fuselage. In both the GUI and command line options, there is an 

optional count option. If provided, CADfix will repeat the copy action that number of times, propagating 

along the translation vector. 

Copying use the GUI: 
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1. Open the “Move/Copy” tool. 

2. Enter “APERTURES” as the item to copy. 

3. Use the “Define…” option to define a 2 meter vector pointing in the positive x axis. 

4. Change the “Count” entry from 1 to 10. 

Copy using the command line: COPY APERTURES ! TRA 2000 0 0 10 

Depending on how you mirrored the first outline, you might have many extraneous points in 

APERTURES.  

 Remove those extra points using: SETR APERTURES FREE P ALL 

The above command will remove all free (read “unused”) points in the set APERTURES. 
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Removing the windows from the fuselage 

The “Create/edit surfaces” tool is powerful and provides a lot of usability improvements over the 

command line equivalent. This is one of the few times where the author suggests the GUI over the 

command line. As such, only the GUI option will be presented here. 

First, we need to group the windows into left and right sections: 

1. Plot just the lines of the APERTURES. 

2. Use the box select tool to select the lines on the right side of the fuselage. 

3. Add the selected lines to a set, RWINDOWS: SETA RWINDOWS SELE 

4. Repeat steps 2 and 3 for the left side of the fuselage, this time using set name LWINDOWS. 

With the lines grouped, we can change the definitions of the fuselage surfaces to include gaps where the 

windows are. 

5. Add the lines of the fuselage to the image. 

6. Open the “Create/edit surfaces” tool. 

7. Select the “Edit” bubble and pick the right side of the fuselage as the entity to be edited. 

The surface definition should populate with four lines and a shape. 
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8. Add the lines of the RWINDOWS set to the definition by typing RWINDOWS in the “Surface 

Edges” entry box and hitting enter. 

9. Hit “Apply.” 

10. Click “OK” in the popup window, making now changes to the embedding geometry. 

11. Repeat steps 7-10 for the left side of the fuselage, this time using LWINDOWS for the new 

edges. 

12. Add the fuselage surfaces to the image. There should now be holes where the windows go. 

Creating a Cable 
Induced currents on cable bundles are often of interest for HIRF problems. We will create a cable that 

goes nose to tail in the simple airplane. The cable will be represented with a line (a special EMA3D 

property will give it some 3D material properties). 

The cable will be a straight cable that connects the nose to the tail: 
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1. Close all sets: SETC ALL 

2. Open a new set, CABLE: SETO CABLE 

3. Plot the lines of the cockpit and the fuselage. 

4. Sweep the point of the nose onto the very back surface of the fuselage: 

a. GUI: 

i. Open “Create/edit lines” 

ii. Select the “Swept lines” option on the left hand side. 

iii. Leave the button on “Create.” 

iv. Select the forward most point of the nose as the sweep point. 

v. Select the “Project to surface” option. 

vi. Select the back surface of the fuselage as the projection surface. 

vii. Click “Apply.” 

b. Command line: 

i. SWEP point1 ! surf, where point1 is the point to sweep and surf is the surface 

onto which point1 will be projected. 

5. Close all sets. 

Geometry Notes 
The intent of this training module is to familiarize the reader with the CADfix and EMA3D interfaces. By 

this point, the reader should’ve seen most of the commonly used GUI aspects of CADfix and been 

introduced to the powerful CADfix command line. Manipulating the model (rotation, translation, and 

zoom) should be comfortable. The reader should understand the basics of controlling what entities are 

shown, or “plotted.” Set management should be beginning to make sense, too. Other training modules 

will teach techniques and methods required to simplify a complex model and make it suitable for a CEM. 
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Steps to EMA3D Simulation 
The process of setting up an EMA3D simulation is outlined in the labelling of the toolboxes. This training 

module will follow the order laid out in the numbering of the toolboxes. 

1) General Topics 
In the top left of the screen, click “Tools->Toolbox->EMA3D_#1_GeneralTopics.” This will open the first 

toolbar for EMA3D, replacing the primitives opened at the beginning of this training. From this toolbar, 

you’ll find “MPIBlocks” and “EFIdnit.” These are easy ways to change the blocking for parallel runs with 

MPI and define an initial E-field value, respectively. 

This airplane model doesn’t need either of those features, so we’ll proceed to number two. 

2) Units 
Click “Tools->Toolbox->EMA3D_#2_SpecifyUnits.” This opens the second toolbar. There’s only one tool, 

labelled “Units.” Click it and confirm millimeters as units. Click “OK.” 

3) Define Lattice 
Click “Tools->Toolbox->EMA3D_#3_DefiineLattice.” There are two tools 

in this toolbox. The first, “ConLatt,” is used to construct 3D lattices. 

We’ll use this one because we have a 3D model. The second tool, 

“TwoDim,” is for 2D problems. Click “ConLatt.” The lattice will define 

the problem space to be simulated and the size of the finite difference 

elements.  

The default values (based on all model geometry) are shown to the 

right. We will change the cell size to 50 mm for all directions. We will 

also change the start and end coordinates for all directions. We will 

add 4-5 cells of space (200-250 mm) between the airplane and the 

boundary of the problem. We can use small boundaries because we 

will use PML boundary conditions, which (when used correctly) don’t 

create many reflections. 
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To check the dimensions of the plane, type: PRNT DIMS PLANE 

This command will print the dimensions of the set PLANE. Use the global minimums and maximums of 

the “Line ends.” The section for “All cords” includes points and shapes that don’t need to be meshed. 
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Be mindful that your maximum y coordinate will likely be 

different than the one shown above. We will want the start 

and end coordinates of the lattice to be even multiples of 

the step. If we increase the boundaries by about 200 mm 

and use the next greatest even multiple, the parameters are 

shown to the right. Click “Apply.” 
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4) Construct Source Geometry 
Click “Tools->Toolbox->EMA3D_#4_ConstructSrcGeom.” An empty toolbox will replace the previous 

one. At this step, the source and detach geometry need to be made. This step is important for 

simulating lightning and ESD problems. However, this model will be used for HIRF. Sources for HIRF are 

typically plane waves, which don’t require constructing any new geometry for attachment or 

detachment. 

There’s nothing to do in this toolbox for this model. 

5) Meshing 
Navigate to “Tools->Toolbox->EMA3D_#5_MeshGeometry.” Three tools should now be visible in the 

toolbox on the right side of the screen. Click the first, “Setup.” This prepared the model for being 

meshed. 

To mesh everything, click the second tool: “Mesh.” Alternatively, you can type MESH into the command 

line. 

On larger and more complex models, it is often advantageous to mesh only a portion of the model to 

reduce computation time. To do this, type: MESH entity into the command line. The entity can be a set 

(DETACH, LEFTWING, etc.), or a piece of geometry (V11, U30, etc.). 

Mesh the entire model: MESH 

Plot the meshed twinkles with the assigned color: PLOT TWI ALL ASGD 

For practice, mesh just the left wing: MESH LEFTWING.  

Repaint the picture. Just the left wing should be showing now. 

We need the entire model, so re-mesh the entire model: MESH. Repaint the picture to confirm the 

entire plane is showing. 
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6) Time step 
Click “Tools->Toolbox->EMA3D_#6_DefineTimeStep.” Two tools should be in the toolbox. Click the first 

button, “TimeStep,” in the toolbox. A window will pop up. Enter 8.0e-11 for the time step and 10e-6 for 

the final simulation time. 

The time step was chosen to satisfy the courant condition without being within 10% of the courant 

value. The margin will provide a more numerically stable simulation. 

Click “Apply.” 

The “MagTSteps” button sets the permittivity scaling for the simulation. This model won’t use this 

feature. Permittivity scaling enforces a quasi-magnetostatic assumption to increase the permittivity of 

free space. Scaling the permittivity allows EMA3D to increase the time step without violating the 

courant condition. The nature of HIRF problems is not magnetostatic, so no permittivity scaling will be 

used.  

7) Background 
Using EMA3D, the background material can be changed. However, we will be using the default values. 

This tool isn’t needed for this model. 
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8) Define Properties 
To run a simulation, EMA3D needs parameters for material properties. To define properties, click “Tools-

>Toolbox->EMA3D_#8_DefineProperties.” Only one tool will occupy the toolbox: “PROPERTY.” Click it. A 

window will pop up. 

Three material properties will be needed for the simple airplane: conductive metallic surfaces, non-

conductive glass surfaces, and perfectly electrically conductive lines. 

1. To make a new material, click “New.” A window will popup: 

2. Enter “METAL” as the name. 

3. Select “Isotropic Surface” for the type. 
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4. Click “Apply.” Another window will popup. Fill in the values as follows: 

The conductivity is that of a typical airplane aluminum scaled for use with 500 mm cells. 

5. Click “OK.” METAL has been defined as a material. 

6. In the “New Property” window, enter CABLEMAT as the name and choose “Thin Wire” as the 

type. 

7. Enter the values shown in the picture. Note that the cable is assumed to be 3 mm in radius 

(which is very big) and the resistance is assumed to be 1 ohm/meter (which is very big). The high 

resistance was chosen so that the induced currents would taper to zero more quickly. 

8. Click “OK.” 

9. In the pop up, click “OK;” there are no parameters to change. 
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You may have noticed that no material was created for the windows. The windows will not get material 

assignments. Without a material, EMA3D will ignore those surfaces and they will act like apertures. This 

is a reasonable approximation for how a window acts in HIRF environments. 

The materials we need have been defined. Now we need to assign them to the parts. The cable will get 

the CABLEMAT material. The rest of the plane will be assigned METAL properties. 

Notice we don’t have a good way of referring to the metallic portions of the plane. The metallic portions 

are the fuselage, cockpit, leftwing, rightwing, and tail. We could either assign the same property to each 

piece (which would be tedious), or we could make a better way to refer to just the metallic portions. In 

other words, make a set that holds just the metallic portions of the plane. 

As mentioned earlier, the metallic portion can be made by adding up the fuselage, wings, and tail. The 

command to do this would be:  

SETA METALLIC FUSELAGE COCKPIT LEFTWING RIGHTWING TAIL 

It’s worth noting that there is a limit to how many additional arguments can be used with SETA and all 

other set commands, so with a larger model this option will require many lines. Alternatively, we know 

that the metallic portions of our model include anything that isn’t a window. We can create a duplicate 

of the PLANE set named METALLIC and remove the windows from METALLIC: 

SETA METALLIC PLANE 

SETR METALLIC WINDOW 

SETR METALLIC APERTURES 

Return to the EMA3D Property Editor window. If you closed it, open it again using the “PROPERTY” tool 

in the toolbox. Click “Assign.” The Assign Property window will pop up. Choose “METAL” from the 

dropdown of available properties. Enter “METALLIC” as the CADfix part. Click “Apply.” 

After clicking “Apply,” change the property to “CABLEMAT.” Enter CABLE as the CADfix part. Click “OK” 

to close apply the change and close the window. 

All material definitions are now applied. Close the property editor. 
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9) MHarness Cables 
Some EMA3D purchases include MHarness. MHarness is used for complex pipe and cable routing and 

probing. The cable in this model is simple enough that MHarness isn’t needed. The MHarness tool 

deserves its own tutorial and is beyond the scope of this training. 
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10) Define Source 
Click “Tools->Toolbox->EMA3D_#10_DefineSources.” The toolbox will now hold many tools. 

Each tool is used for different kinds of sources. Sources can be plane waves, magnetic current 

densities, among many others. We will use a plane wave source. Before the source definition 

is created, we need to make a source waveform file. 

Click on “Source_Tool.” It is the last tool in the current toolbox. A new window will open. It is 

the EMA3D source tool. Use the “Gaussian” option in the “Select Analytic Function and Time 

Values:” dropdown. Change the final time to 10e-6 seconds. Fill in the rest of the values based 

on the picture below. 

The peak time parameter was chosen so that the first value in the source file has a value of 

zero. EMA3D will throw an error if a source file doesn’t start with zero. 

 

Note the name of the file created. In the example the name is “gaussian.dat.” Click “Finished.” 

In the popup, click “OK.” 
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 To define a plane wave source: 

1. Click on the “PW_Source” button 

2. Enter “gaussian.dat” as the source filename 

3. In the “Huygen’s Surface” section, click the “Auto-Place” button. 

4. Click the adjacent “Show Surface” button and ensure that no parts of the plane extend past the 

Huygen’s surface. 

5. For a broadside propagation vector, enter zero degrees for theta and phi. 

6. To align the E-field with the long axis of the aircraft, enter 90 degrees for alpha, zero degrees for 

beta. 

7. Click “Create PW Source.” 
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11) Boundary Conditions 
Click “Tools->Toolbox->EMA3D_#11_SelectBdyConds.” Click the only tool in this toolbox. A window will 

appear. Check “ALL” on the “PML” row. The PML (Perfectly Matched Layer) option is an absorbing 

boundary condition has been used with HIRF simulation models with great results. 

Leave the bottom three entry fields as the defaults. Click “Apply.” 

12) Probes 
For a simulation to be useful, it needs to write data. Probes determine what data is written as outputs 

from the simulation. For this simple airplane, we will make bulk current probes near the front and rear 

of the cable. We will also make e-field probes in space near the bulk current probes. 

Creating any probe will require going into: “Tools->Toolbox->EMA3D_#12_DefineProbes.” The toolbox 

should now have many tools in it.  

Bulk Current Probe Geometry 
The first probe will be a bulk current probe on the cable, near the nose of the aircraft. Bulk current 

probes work by integrating the magnetic fields around rectangular region defined by two points. The 

two points are the opposite corners of the rectangle. To measure current on a cable, only one point is 

needed (the magnetic fields are integrated around that point). The should lie exactly on the mesh grid.  

1. Plot the cockpit lines in one color, then the cable in another: 

PLOT L COCKPIT 

PLUS L CABLE G 

2. Open a set to contain all probes: SETO PROBES 

3. Open another set to contain just the forward current probe: SETO CURPROBE1 

4. Using your preferred method, create a point at (-200, 0, 0): PNT ! -200 0 0 

5. Close the forward current probe set: SETC CURPROBE1 

6. Open a set for the rear current probe: SETO CURPROBE2 
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7. Using your preferred method, create a point at (34000, 0, 0): PNT ! 34000 0 0 

8. Close the set for the rear current probe: SETC CURPROBE2 

Bulk Probe Properties 
To apply the bulk current probe definitions to the points, change the toolbox back to the Define Probes 

toolbox: Tools-Toolbox_EMA3D_#12_DefineProbes. 

1. Click “BulkCurr” in the toolbox. 

2. A window will pop up. Fill it out as shown: 

3. The bounding point is the point in the set CURPROBE1. To find its name, either: 

a. Add the labelled point to the image: PLUS PA CURPROBE1 

b. Print the point in RWPROBE: PRNT P CURPROBE1 

4. Enter the point name in both of the bounding point fields. 

5. Click “APPLY.” 

6. Change the set name field to CURPROBE2. 

7. Change the bounding point to the point in the CURPROBE2 set. Leave the time fields and normal 

direction unchanged. 

8. Click “OK.” The bulk current probes have been defined. 

E-Field Probe Geometry 
The e-field probes will also be located at a point. Create these points: 

1. With the PROBES set still open, copy the CURPROBE1 up 400 mm. Name the set EPROBE1: 

COPY CURPROBE1 EPROBE1 TRA 0 400 0 

2. Repeat step one for CURPROBE2, creating EPROBE2. Use the same translation. 

E-Field Probe Properties 
1. Click the “New2” button in the Probes toolbox. 

2. Enter EPROBE1 as the probe set name. 

3. Pick or enter the point name for EPROBE1. 

4. Click the checkbox for “Ex-Field Physical Property Name” 
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5. Leave the radial buttons unchanged. 

6. Enter the start time as 0.0 

7. Enter the stop time as 10e-6 

8. Enter the step time as 8e-11 

9. Click “Apply.” 

10. Repeat steps 2-9 for EPROBE2. 

EMA3D Review Tool 
Change the toolbox to the Review Tool: “Tools->Toolbox->EMA3D_ReviewTool.” Click the “Review” tool. 

A window will pop up. It should look like: 
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Click “Create EMA3D Input File.” Another popup window will appear. Nothing needs to be changed; click 

“OK.” 

When the emin file is created, click “OK” again. Close the review tool window. 

Running EMA3D 
Change the toolbox to the Run EMA3D toolbox: “Tools->Toolbox->EMA3D_Run.” Click the only button, 

labelled “Run_EMA3D.” The EMA3D window will appear, although it might take a moment. 

Click the “Run New EMA3D Simulation” radio button. 

Click “Browse” to find the emin file created earlier. 

Click “Run EMA3D.” This simulation will likely take a day or two. 
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Post-Processing 
There are many ways to post process data output by an EMA3D simulation. The EMA3D GUI has built in 

options for plotting probe outputs. However, large models have hundreds of probes and it is not 

practical to rely on GUI’s for such large projects. It is common to build application specific, high volume 

scripts and tools for large projects. Many EMA3D probes output data as .dat files. These files, if in time 

domain, have time values in the first column and data values in the subsequent columns. Columns are 

separated by whitespace. These files are easy to use with MATlab, Mathematica, Python, etc. 

Not all EMA3D probes output .dat files. Probes that have visual output will often use postscript or 

.emout file types. For example, animation probes output emout files and slice probes output postscript 

files. This training document didn’t have any such files. Only .dat files were generated by the simple 

simulation. 

EMA3D GUI Processing 
Once the data files have been created, you can double click them in the Probe window to access the 

data. Because all of the data made by this simulation only have one column, only one possible plot in 

the data window. Double click a column to see its plot. Probes can be plotted one on top of another. 

Probes can be plotted while the simulation is still in progress. 

If the simulation has finished, use the “Analyze Existing Results” button in the EMA3D GUI. Use the 

“Browse” to find the simulated emin file and click “Open.” 
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Click “Analyze Results.” The tables on the left side of the window should now be labelled and populated. 
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Double clicking an entry in the probe list (upper of the two tables on the left side) will populate the 

lower table with details and column numbers of the selected probe. Instead of double clicking, you can 

click the “Analyze Probe” button. 
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All of the probes used in this demo only have one column, so the lower table will only have one row. 

Double clicking an entry in the lower table will plot the entry on the right side of the window. Instead of 

double clicking, you can use the “Plot on Update” button. 

With a probe plotted in the time domain, you can use the “Plot FFT” button to plot the frequency 

components of the probe. Once the FFT has been calculated, you can use the “Set TF Numerator”/”Set 

TF Denominator” buttons to assign the currently plotted FFT as the numerator/denominator of a 

transfer function. Typically, the source will be the denominator. With both the numerator and 

denominator assigned, you can plot a transfer function. You can also export the time domain, frequency 

domain, or transfer function data as text files using the other buttons in the GUI. 


